Unable To Find Database DLL (CR 8.5)

Problem:

When application is deployed using Crystal Reports 8.5 (CR 8.5), the following exception occurs when generating reports...

unable to find database dll

This is because you are not using Crystal Report 8.5 ActiveX Designer RunTime Library (craxdrt.dll)

Check out here for complete solution. Or just download the tutorial.

This solution also cater for the other error of 'Physical Database Not Found'

The other good reference site is here.

Comments

Brandon Teoh said…
Related Issues:

CRViewer Export Button not working

It is indeed true, you have to put and register those mentioned dlls in the 'Windows\System32' folder.

Then the export dialog box will appear.

If you are using installer, configure those dlls into the 'Windows\System32' folder.
crystal report said…
Crystal Report (8.5) is not working on win7/windows 2008 64 bit system

My application is a vb application and I am using Crystal report 8.5. It is working fine on 32 bit system and 64 bit system of Windows 2003 server. When I run the same application either on win7 64 bit or on 2008 64 bit, report does not open.
I am using vb script to access the database.
Part of the code written in the VB script file is as follows:
Dim objrsRecordSet 'As RecordSet
Dim strSQL 'As String

'**** Open Database Connection using the parameters passed from the main program
Set dbConnection = CreateObject("ADODB.Connection")
dbConnection.ConnectionString = "Provider=SQLOLEDB;Server=" & mstrServer & ";uid=" & mstrUserName _
& ";pwd=" & mstrPassword & ";Database=" & mstrDatabase & ";"

dbConnection.Open
dbConnection.CommandTimeout = 200

dbConnection.Properties("Enable Fastload").Value = True




Basically we have two visual basic projects developed in VB 6.0 language: let’s say
1. Diapp (we consume the report.dll in this application, in order to generating the reports)
2. Adacrystalapp (which is used for making the report.dll)


Diapp application generating the reports on windows-XP(32 bit machines) without any problems but when I run the same application on 64 bit machines(win7/Vista…etc) report is not generating.
If I run the both applications (Diapp, Adacrystalapp) in debug mode then reports are generating on 64 bit machines (win7/vista) also without any problems.



Please help me out with this issue, i will appreciate for your response.
Brandon Teoh said…
hi Dude,

I don't think Crystal Report (8.5) has deployment for 64 bits support. CR 8.5 is like 10 - 15 years old. VB6 which comes under Visual Studio 98 is about 15 years old man.

Well, I can't be too sure as I haven't tried installing and deploying CR 8.5 on 64 bits Windows platform.

The only thing I a definitely sure is that CR 8.5 is no longer supported by neither Business Objects or SAP for a long time.

Based on my experience, it will shouldn't work. You need to migrate your codes and everything to VB.NET 2008 at least - Visual Studio 2008 comes with built-in Crystal report..

But you did mention that you have tried running it on 64 bits platform under debug mode ?

Let me try it out and see.